INC-3796 (P1- High Priority)

Incident Report for Yoti

Postmortem

Monday 20 July 2026 from 09:44 UTC - 10:20 UTC

We recently experienced a temporary disruption affecting our Identity Verification service in the USA.

Our Network Operations Centre (NOC) quickly identified the root cause as a brief fault within our load balancing system. While this caused a short outage for some users, our infrastructure team has resolved the issue, and all services have been fully restored to normal operations.

We sincerely apologise for any inconvenience this may have caused. We are currently conducting a thorough post-incident review to strengthen our systems and prevent this from happening again.

Posted Jul 20, 2026 - 11:52 UTC

Resolved

The Identity verification service(USA) service is now fully operational. The incident has been successfully resolved and all systems are stable. Thank you for your patience.
Posted Jul 20, 2026 - 10:20 UTC

Monitoring

A fix has been implemented for the Identity verification service(USA) service, and we are seeing signs of recovery. Our team will continue to monitor the system closely to ensure stability before officially resolving the incident.
Posted Jul 20, 2026 - 10:18 UTC

Investigating

We are currently investigating an issue affecting the Identity verification service(USA). Some customers may experience intermittent performance or downtime.
Posted Jul 20, 2026 - 09:44 UTC
This incident affected: USA1 (Identity verification).