INC-3380 (P1 - High Priority)

Incident Report for Yoti

Postmortem

Tuesday 26th August 2025 from 12:30 UTC - 13:30 UTC

We're writing to inform you about a service interruption that affected Yoti services today.

This was caused by an unexpected internal network gateway issue in our primary data center. Our Network Operations Center (NOC) immediately escalated the issue to our infrastructure team, who quickly re-routed all traffic to our secondary data center and fully restored all services.

We sincerely apologise for any inconvenience this outage caused you. We understand the importance of reliable service and are reviewing this incident to further improve the resilience of our network. We apologise again for any inconvenience this may have caused our customers.

Posted Aug 26, 2025 - 17:04 UTC

Resolved

The Digital ID, Identity verification, Identity verification portal, Age verification, Age estimation, eSignatures, Yoti Hub, Yoti Website, Yoti Password Manager, Yoti Web Account, UK Post Office In-branch verification (IBV) services are fully operational. This incident has been resolved.
Posted Aug 26, 2025 - 14:59 UTC

Monitoring

We have fixed the Age verification service. Our engineers will monitor the situation until we declare the incident resolved.
Posted Aug 26, 2025 - 14:51 UTC

Update

We are continuing to investigate this issue.
Posted Aug 26, 2025 - 14:35 UTC

Investigating

We are experiencing issues with Age verification service.
Posted Aug 26, 2025 - 13:56 UTC

Monitoring

All our services have returned to normal. Our engineers will monitor the situation until we declare the incident resolved.
Posted Aug 26, 2025 - 13:22 UTC

Update

We are continuing to investigate this issue.
Posted Aug 26, 2025 - 13:12 UTC

Update

We are experiencing issues with the Digital ID, Identity verification, Identity verification portal, Age verification, Age estimation, eSignatures, Yoti Hub, Yoti Website, Yoti Password Manager, Yoti Web Account, UK Post Office In-branch verification (IBV), services.
Posted Aug 26, 2025 - 12:57 UTC

Investigating

We are experiencing issues with the Digital ID, Identity verification, Identity verification portal, Age verification, Age estimation, eSignatures services.
Posted Aug 26, 2025 - 12:30 UTC
This incident affected: Global (Digital ID, Identity verification, Identity verification portal, Age verification, Age estimation, eSignatures, Yoti Hub, Yoti Website, Yoti Password Manager, Yoti Web Account, UK Post Office In-branch verification (IBV)) and USA1 (Identity verification, Age verification, Age estimation).